Engine Yard Blog RSS Feed

Earlier this summer, in an effort to help our customers keep up to date with newer gem libraries and security updates, we offered a newer version of RubyGems (1.8.17) in one of our stack upgrades. Some legacy applications began having incompatibility issues with this newer version of RubyGems. Certain crucial gems would break in this process and cause complications for running your applications. As a result, RubyGems was no longer upgraded automatically.

Starting today, you can specify the version of RubyGems you would like to have installed, per environment.

With this new feature, if you are using an older version of Ruby (1.8.6 or 1.8.7), you can specify which version of RubyGems should be set for a particular environment. This will allow the environment to be able to receive other upgrades, like updates to Nginx, but not receive an upgrade to RubyGems.

Use the RubyGems feature

The next time you go to the environment UI, the RubyGems drop-down will appear.

To get to the environment UI

  • For your existing environment, click Edit Environment under the More Options section.
  • Or, from your app's Environments page, click Create New Environment.

Tagged:

comments powered by Disqus